Some people build Models, others build CNC PLASMA machines

Discussion in 'CNC Machines and Conversions' started by rodw, Aug 20, 2016.

Help Support HMEM by donating:

  1. Jul 20, 2017 #61

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Well, I had a bit of a rethink about the ohmic sensor on a torch that does not have a shield as its the cutting tip that hits the plate so I moved onto other things. I spent a day and a half last weekend soldering up all of the connectors on the case

    [​IMG]

    And an SMA coax connector for the wireless pendant closer to the top of the enclosure.

    [​IMG]

    I had one stuffup that cost me hours trying to work out why the gantry was not homing correctly. Eventually today I worked out that I had accidently plugged the 5V stepper controller wiring back into the wrong controllers so stepgen 0 n the 7i76e was wired up to joint 1. This was OK except that the home and limit switches were unaffected. so when we homed, the wrong switch was triggered so the wrong motor kept running.

    That will be all double dutch to anybody that is not using the new LinuxCNC joint axis homing sequence for gantries. What happens when homing is that the gantry heads towards the homing switches and when the first side hits the homing switch, it waits for the other side to catch up. Once it catches up, each side moves to the specified offset and then home is set.

    The good part about this is that you can home the gantry in software by altering the offsets. In my case, the offsets were different by 2mm between sides to square the gantry.

    The problem I had was the wrong side was trying to catchup which did not work very well... :cry: I only worked it out after I really slowed down the homing velocities so I could see what was going on.

    Anyway, If I can massage a Sheetcam post processor, I might even be able to cut something this weekend! But don't hold your breath as I've got a busy few days coming up!

    I also have a couple more wires to add to the cabinet for the 5th axis and a couple more things so I can seal the cabinet up once and for all. None of these are critical for the present config though.
     
  2. Jul 22, 2017 #62

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Its Alive!

    https://youtu.be/zVM5Tz4Tzm4

    We had a lot of trouble this morning. I've had the machine torch for 12 months but this was the first time I had plugged it into the machine. The torch came on with the machine and would not go out. Then we tested the hand torch and we could control it from LinuxCNC without having the trigger pressed. So after comparing wiring between the two torches, I cut one wire inside the machine torch so it looked like there was a switch turned off and everything worked perfectly.Well it sounds simple but the process took several hours of troubleshooting!

    I've still got some things to sort out. I'm not sure why the flame goes out on startup. We did edit the gcode a bit and got the outer circle to cut perfectly.

    I was not seeing an ArcOK signal or a torch voltage. I hope it is just a wiring fault in the cable I made up.

    I spent about $300 on air fittings in preparation for setting up an engraver but that can wait for a while...

    I have so much work to do to set up Sheetcam and work out the right cutting speeds.
     
  3. Jul 22, 2017 #63

    ShopShoe

    ShopShoe

    ShopShoe

    Senior Member

    Joined:
    Oct 2, 2010
    Messages:
    909
    Likes Received:
    163
    That's great to see running. I believe you will get the rest of things sorted.

    Thanks again for posting this thread and all the details.

    --ShopShoe
     
    rodw likes this.
  4. Jul 23, 2017 #64

    Johno1958

    Johno1958

    Johno1958

    Well-Known Member Project of the Month Winner HMEM Supporter

    Joined:
    Sep 19, 2015
    Messages:
    218
    Likes Received:
    73
    Good to see it up and running Rod. I'm sure you'll get on top of those teething problems .
    Cheers
    John
     
    rodw likes this.
  5. Jul 23, 2017 #65

    joco-nz

    joco-nz

    joco-nz

    Well-Known Member

    Joined:
    Feb 21, 2016
    Messages:
    526
    Likes Received:
    171
    Impressive to see it moving and cutting! Awesome work. Teething problems ... pah! After what you have achieved to date I can't seem them evading you for long.

    Cheers,
    J.
     
    rodw likes this.
  6. Jul 23, 2017 #66

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Thanks guys, James, you are right!

    I knew nothing about Linux CNC
    I knew nothing about CNC in general
    I knew nothing about Gcode
    I knew nothing about Plasma cutters

    But today I managed to cut a donut!

    [​IMG]

    I solved the torch voltage issue by plugging in the connector. What a dope!

    Then I found one of the Arc OK signals had been soldered to a pin in the interconnect cable that was not connected inside the plasma cutter! I wonder who did that?

    Because I knew nothing about my plasma cutter, I did not know that it tries multiple times to establish an arc with a pause in between. So the reason why part of the cut was skipped at the beginning was that I was attempting to pierce too high and the plasma cutter did not get a good arc and turned off and retried just as we were started moving. Lowering the pierce height to 3mm fixed the issue.

    I'm still not convinced I've got the ArcOK signal working properly, but that won't take much to sort out and then hopefully, I can say the wiring is finished. Here's just a small part of it.

    [​IMG]
     
    bruedney and joco-nz like this.
  7. Jul 31, 2017 #67

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    I did not get much done over the weekend or so it seems

    I wrote a small program to make a series of cuts at different speeds
    [​IMG]

    I started with cuts at 100 mm/min apart, zeroed in on the best looking one and then repeated (several times) at 10 mm/min apart.

    So now I have the machine dialed in for 2mm mild steel. As part of this, I told LCNC to log the torch voltage (at 1000 times a second) I kinda forgot about this for a while and the next thing I knew was I had an 8 gb text file!

    I also was able to do a bit of debugging of some signals and checked the code for one component I'd written becasue I was only showing a voltage of about 20 volts. This was due to a software error in my C code. I was only out by a factor of 20.

    I think I need to revisit the calibration resistor in the torch voltage circuit becasue I think the THCAD board is receiving a voltage above its full scale range. After fixing my error, the THCAD should have a full scale reading of 320 volts but I think it is getting up around 400-500 volts on startup.

    I need to spend some more time cutting while checking some internal signals in LinuxCNC and also with a volt meter. I did debug a bit more of my config. Some of it I did so long ago, I had forgotten how it worked. I'd added a delay on the THC enable signal and I was able to confirm that all of my THC enabling logic (3-4 things must be true before the THC is engaged).

    So once I know I've got the torch voltage nailed, I will be able to look at the Torch height control. Once I get this far, I'll be on my own as I have not seen anybody else using the new experimental LinuxCNC branch on a live machine. I really hope it works!
     
    joco-nz likes this.
  8. Aug 7, 2017 #68

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    I'm afraid nothing much has happened the last couple of weekends Because I did not have the confidence the torch voltage and dividers were correct. So I decided to hack the probes off a cheap set of multi meter cutters and solder them onto the raw voltage output on the CNC port

    [​IMG]

    This let me plug a multimeter in to read the raw arc voltage while cutting

    [​IMG]

    While I was doing this, I fired up halsampler in a new terminal window and it logged the voltage and a few other things 1000 times a second

    [​IMG]

    And something clearly was not right with the voltage divider. So I pulled the plasma cutter apart to access the CNC board so I could change the divider ratio by changing a link on the board which the manual said selected between 16:1 and 50:1.

    [​IMG]

    And nothing changed! Grrr

    So I pulled the board out of the machine and inspected it in the sun to find that the manual was wrong! So a few more testcuts later, neither divider was showing correct results.

    So I stopped and phoned a friend and I walked down the road to his place and he traced out the circuit for me. Still with nothing definitive I wandered home quite despondent. The next morning, I spent hours analysing the board and drawing out the circuit. Still with no further progress and after thinking about a few things and a bit of research, I decided That the best way to do this was to connect a known voltage somewhere in the cutting volts range to the board and make some accurate voltage readings.

    I had a couple of 48 volt power supplies so I decided to join them in series to get 96 volts.

    [​IMG]

    Pretty close, all 17 amps of it!

    [​IMG]

    So I took a deep breath and plugged it in.

    [​IMG]

    And put a high quality multimeter on the raw outputs.

    [​IMG]

    You can see the voltage dropped a couple of volts because of the 100k resistors on the raw voltage outputs to prevent arcing.

    So now I could measure the divided voltage

    [​IMG]

    and I could also read the data back in LinuxCNC. I had a discrepancy for a while until I remembered I had a scaling resistor in the cable and I was reading the voltage after it. Sure enough, when I read the voltage before the resistor it was perfect.

    Time to do the maths! No wonder I was in trouble. The dividers were out by a factor of 1.5. The 50:1 divider was actually reading 75:1 and the 16:1 one was showing 24:1.

    So A quick tweak of the calibration settings in LinuxCNC and I was getting a perfect result within +- 0.7% on the voltage sensing circuit! Finally! So now I can actually get on with setting this puppy up!
     
    joco-nz likes this.
  9. Aug 20, 2017 #69

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Well, finally I have got the software working and the THC seems to be working pretty good on the very first cut.

    [​IMG]

    The green line is the torch voltage, the white line it follows is the desired 85 volt set point and the blue line on the bottom right is the error which is printed at a higher scale. The beginning of the blue line is where the THC was enabled.
     
  10. Feb 13, 2019 #70

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Its been ages since I updated this thread. I did get this table pretty well finished
    [​IMG]

    I had a lot of troubles with the experimental software I was running and kinda lost interest for a while. Then I sold the plasma cutter with the intention of buying a Hypertherm XP45. Then I moved my business out of home into an industrial shed with 3 phase power so I thought I'd be better off with a Hypertherm 65 amp machine to cut some of the heavier plate I use.

    But then I found a brand new old stock Thermal Dynamics A120 (120 amps) machine earlier this month at a price I could not walk past.

    [​IMG]

    So now I can pierce 16mm thick mild steel!

    It took a few days to get it all wired back in and the torch lead fed back though the machine and I was able to tune the machine much better than the cheap Everlast.

    So two weekends ago I wanted to get it finally configured so I could cut some parts for a prototype product.

    Then everything went downhill due to water in the air lines due to our hot, humid climate. So last Monday week I decided to purchase a refrigerated dryer. But before I purchased it, I read in the manual that you should fit a precooler to the air line in front of the dryer. So I learnt a bit more about precoolers and I found they should be fitted between the compressor and the air tank.

    I found some ideas online so I headed off to one of my suppliers to buy an oil cooler for a vehicle and came up with this.

    [​IMG]

    This works an absolute treat! The top pipe is so hot, you can't touch it and the bottom one is cool to the touch! The autodrain at the bottom does remove some water but I think I need to change the pipe work so it sits lower down in a u shaped piece of pipework.

    So now the air is cool before it goes through the refrigerated dryer

    [​IMG]

    So the night after I got it all running I did not have the compressor turned of and a seal blew on the motorguard filter mounted to the table earlier in this thread so it ran all night. There was 3 litres of water in the tank but the dessiant crystal on the table were unchanged so I now know not a skerrick of water gets past the refrigerated dryer. Plus it includes prefilters and post filters on it so I dumped all of the regulators and filters fitted to the table as they are no longer required. I have an auto drain for the compressor tank on order so once it arrives, I'll have the best air setup in Australia!

    I've had a fair bit of tweaking in the Sheetcam post processor to get everything running smoothly and I hope I made the last mods this afternoon and I can get on with cutting out prototype parts. Anyway, here is a video earlier this week. 8 mm plate, 80 amps at 1945 mm per minute. There ar 4 holes in the hob but we elected not to pierce each one and instead just cut a line into them to save our consumables when we get to 16mm plate.



    So here is the result. an prototype of a bash plate with inbuilt recovery points that makes more room for a relocated swaybar.
    [​IMG]

    Ultimately, these will be cut from 16mm plate and today I bought 1.2m of 16mm and 12mm barstock wide enough to cut these parts out of. With a bit of luck that will be tomorrow's project!

    To finish this off, I desperately need to build the downdraft hopper I've designed as it makes an awful mess!
     
    minh-thanh likes this.
  11. Feb 13, 2019 #71

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    I forgot to mention. There are two things to watch in the video. one is about half way through is the shaft joiner hopping around as it tracks variations in the torch voltage. The other thing is the magnetic torch breakaway activating right at the end of the cut. This was because sheetcam chose a really tight spot to start from so when it got to the end of the cut there was no metal there. So the voltage leaps up really quickly so the controller thinks the torch is way off the plate so moves it down and causes the crash. The solution to this is to write a void crossing component for LinuxCNC to disable the torch height controller when it sees the voltage spike. Also in our next cuts, we've created some sheetcam rules that slow the velocity down on holes and arcs. This seems to have made a marked difference to hole cut quality. So much to learn!
     
    deeferdog likes this.
  12. Feb 13, 2019 #72

    Scott_M

    Scott_M

    Scott_M

    Well-Known Member

    Joined:
    Apr 13, 2013
    Messages:
    248
    Likes Received:
    75
    Location:
    Medina, Ohio USA
    NICE !!!

    Looking good Rod. I was wondering about that end shot, it looked like a crash. Thanks for the explanation. Almost there.

    Scott
     
  13. Feb 13, 2019 #73

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Thanks Scott. That was actually the first crash with this plasma cutter. I had some spectacular ones with the old machine. In this case it was user error becasue I was too impatient to learn how to change the start point in Sheetcam. The previous ones were usually due to poor tuning resulting in oscillations that exceeded the cut height.

    Anyway, the issue has been you can't test any stuff for this until you have a working plasma cutter to work with. I had one go at it and failed so I put it aside for now. The solution is track a moving average of the last N readings (N = 10, 20, 100 etc, I don't know yet) and compare the change in voltage over time (dv/dt). It will probably idle along around +- 100 volts per second and crossing the void might push that to 3000 volts per second or more so it will be a matter of picking a threshold (say 1000 volts per second) that if its exceeded in a positive direction, to hold the height adjustments.

    It quite a complex piece of C code to do this as averaging implies a loop but you should not run loops in interrupt service routines that fire every millisecond. But you've just given me an idea to try. I'll add an output pin to an existing component for the dv/dt so at least I can see the issue in real time.
     
    Scott_M likes this.
  14. Feb 13, 2019 #74

    Scott_M

    Scott_M

    Scott_M

    Well-Known Member

    Joined:
    Apr 13, 2013
    Messages:
    248
    Likes Received:
    75
    Location:
    Medina, Ohio USA
    If you think the code is complex, I'm sure it's waaaay over my head.
    Do you have a way to record your real time tracking ? It would be convenient to analyze it after the fact.

    Very impressive work so far, I have no doubt that you will get it.

    Keep us posted.

    Scott
     
  15. Feb 13, 2019 #75

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Scott yes.
    There are two ways. One is to use Linuxcnc/c built in oscilloscope that lets you measure signals every millisecond. The green line here is the plot of torch voltage and the blue line at the bottom is the error (difference between actual and desired volts). The error signal starts jumping around a little bit once the THC is enabled. There is a pink line there which is the ac ok signal back from the plasma cutter which happens near the pierce and the THC is enabled 1.5 seconds later. This is what I've used mostly. Its extensively used to tune servos etc when doing retrofits.
    [​IMG]

    The other way is to use a real time component and a separate program to sample signals every millisecond and write it to a file. I used this to do some regression on torch voltage based on a sample of 16000 readings. It showed a very linear response of 7.53 volts per 1.0 mm with 99.4% confidence on my old plasma cutter. This gave me some real insights into torch voltage behaviour.
     
  16. Feb 14, 2019 #76

    Scott_M

    Scott_M

    Scott_M

    Well-Known Member

    Joined:
    Apr 13, 2013
    Messages:
    248
    Likes Received:
    75
    Location:
    Medina, Ohio USA
    Well that is certainly handy to have "on board" , don't even have to hook it up. :)

    Thanks for the explanation and now that you mention it I do remember seeing the HAL oscope. Both of my Tormach machines ( lathe and mill ) run PathPilot which is Linux and I am slooowly getting more familiar with Linux. It certainly brings out the geek in a person though :)

    I have confidence in your coding Foo , let me know how it works out.

    Being able to pierce 16mm is pretty serious, makes for a robust machine and, it's in house. And nice work on the air compressor.

    Scott
     
  17. Feb 15, 2019 #77

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Well, the 16mm went OK. 1350 mm/min at 120 amps
     
    minh-thanh likes this.
  18. Feb 15, 2019 #78

    Scott_M

    Scott_M

    Scott_M

    Well-Known Member

    Joined:
    Apr 13, 2013
    Messages:
    248
    Likes Received:
    75
    Location:
    Medina, Ohio USA
    Very impressive !

    What kind of amperage does it take to do the initial pierce ? Was that 120 as well ? It just blows right through it :)

    I also noticed a bit of mismatch of the start and end cut. Is that designed ? I wouldn't think the work moved.

    Scott

    Capture3.JPG
     
  19. Feb 15, 2019 #79

    rodw

    rodw

    rodw

    Well-Known Member

    Joined:
    Dec 3, 2012
    Messages:
    1,123
    Likes Received:
    334
    Scott, plasmas are constant current devices so its 120 amps all the way. Some machines can do a soft pierce and ramp up the current during the pierce to reduce the puddle splashing around to improve consumable life but this one has no such control. Yes I had to double check the pierce delay against the book settings as it was only 0.7 seconds! We probe for the surface, start above the cutting height (pierce height), turn it on, wait for an ArcOK signal from the plasma and then wait out the delay before commencing the cut.

    I'm not sure about the finish of the cut being out. It cleaned up OK. I know I have to rework the torch breakaway as it has some wobble in it. One issue is that the bottom of the cut lags behind the top so its recommended to continue past the start point but when I tried this the THC did not like it so I disabled it. It could be related to that. Overriding Sheetcam's chosen start point so it was away from a corner helped. I've since added a torch off delay of 0.1 seconds so I'll see how that goes.
     
  20. Feb 15, 2019 #80

    Scott_M

    Scott_M

    Scott_M

    Well-Known Member

    Joined:
    Apr 13, 2013
    Messages:
    248
    Likes Received:
    75
    Location:
    Medina, Ohio USA
    Thanks Rod
    Also what air psi does this run at and what kind of cfm do you need? ( just curious )

    Scott
     

Share This Page