Help with Mach3 and 4th axis machining

Home Model Engine Machinist Forum

Help Support Home Model Engine Machinist Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.
Or maybe for a quick test see if you can stall it out. (don't use your hand) Program something like G0 A720 in the DRO and hit enter then see how much torque it has or if it even makes the 2 full turns.
I'm pretty sure that there is no mechanical issue with the 4th axis, but I did take is partially apart to look into it (pun?). I ran that code again, air machining, and there are 2 places where is stops all movement for about 2 seconds, but the screen DRO shows the code moving and the A-axis rotating (which it isn't). When it temporarily stops, the rotary unit makes a sort of whining sound.

I did find reference on the net to mach3 missing steps when using the A and Z axis; exactly what I'm finding. Just started looking into this to see if there are any settings I can tweak. I'll attach the code I used. Should produce a single lobe cam about .155" wide.


  • single lobe cam.txt
    134.1 KB · Views: 67
if you are missing steps there is a mechanical problem. Try running A720 f150 in the dro that is about the speed you were going when it was not moving. Also note the location ( degree wise ) when it stops. See if there is a tight spot there.

I just looked at the code in NCPlot and it looks fine.
My 4th axis has a lever that I can engage/disengage the stepper pinion and rotate the table freely. Does yours? It would be an easy way to check for a tight spot. Or it may just be going too slow at that point. I would also note the position it happens at. Is the unit well lubricated?

That is a good find, if the machine thinks the A axis is turning, but it is not, it looks like you said, a hardware or software error. How fast are you turning your A axis? can you try once at a much slower speed? how strong is your driver? I had to upgrade my A-axis motor driver becasue I was having a similar issue, I did not have enough torque and was loosing position. And like Scott suggested, I found out becasue it was not correctly returning to 0 degrees.
Not sure what section this should go in, but I'll start here. I'll try and keep this brief, but probably won't be able to. ;)

So, here is what is going on. I'm going to machine the camshaft for my Little Demon engine using my small CNC mill with the rotary axis. I have DeskProto software. It will handle the 4th axis, but not being super expensive top-of-the-line software, it does't handle multiple axis movement while using the rotary axis. So it can rotate the part while moving the cutter up and down (Z-axis), or can rotate the cutter while moving the part axially (X-axis). Both ways should be suitable for producing a cam. It can't move the X, Y, and Z while rotating.

So I did some test pieces in aluminum and found I was getting a real mess. Lex, at DeskProto, is very good at helping and we have gone back and forth for over a week to try and sort this out, with no resolution. One issue is that Lex does not use Mach3 so can't say if I have settings wrong. To help things along, I did a quick model of the cam with only 1 lobe as a test piece. The software lets you specify machining around the A-axis (so rotating while moving the cutter up and down to produce a cam lobe) or you can specify cutting along the X-axis; this would be what is sometimes referred to as indexed cutting. Make a cut along the length of the part, turn it a degree or 2 and repeat.

When I specify cutting along the X-axis, I get a good part. This is 1/2" diameter material, machined in advance to around 1/4" to chuck in the mill. It is machined with a 1/8" flat end mill and seemed to be indexing about 2 degrees for each cut. A perfectly acceptable cam lobe:

View attachment 133725

But before I did this, I was specifying machining around the A-axis and got this. This was with the same 1/8" flat end mill. The machining is decent (a little strange in one area), but the cam lobe is almost round. It is the one on the right.

View attachment 133731

In both cases it did rough machining and then finish machining, both with the same cutter. Since it is just 1 cam lobe it was only about 5 minutes to machine.

Now while the machining along the X-axis is producing a good part and I can use that to do the camshaft, I would really like to sort out why I can't use machining around the A-axis. I have checked my settings in Mach3, primarily in General Configuration not having any boxes checked in the rotational section, and having Angular Properties checked. This was specified by Lex for DeskProto.

I passed the file onto Lex and he ran it on his machine and got a decent cam shape. But as I said, he is not using Mach3.

I can see from the 2 G-code files that they are both machining to about the same depth, but it seems that the one with around A-axis machining is carrying that depth too far around....but not on Lex's machine. Very strange.

If anyone has seen anything like this before or can offer suggestions it would be great. I know it is asking a lot, but if anyone is willing to try machining one with the "around A-axis" code that would be fantastic. You should get a cam lobe with around .070" lift. The starting point is a piece with 1/2" diameter, machined down to .25-.3" beside the lobe. The lobe is .155" wide and the 0,0,0 point is the top of the part, left side of the lobe, centred on Y-axis as shown:

View attachment 133732

Thank you very much in advance (for those I haven't lost by now),

I was hesitant to reply since I can not do the machining that you are doing. However, on rare occasions I have found the software or calculations to be correct and the machine doing what it was supposed to be doing but an incompatible set up causing the problem. I suspect that if the came was rotated 90 degrees you would make a good cam because the cutter would be able to cut closer to the line commanded by the software. And its possible if you used a small as diameter cutter as possible you would improve the odds since the geometry of the bit and cam line could match better. Its just a thought.
OK, progress report.

I took the 4th axis apart. It looked good inside. Grease was fresh and with the stepper motor removed I could turn it easily and freely in both directions. Cleaned out the grease anyways, put in new stuff and put it back together. Ran it around in both directions for while with an electric drill on the worm drive shaft. Turned it by hand again and still nice and free. Put the stepper motor back on and could still turn it nicely, other than the usual bumping drag of the stepper.

Put it back on the CNC and ran the A720 F150 code. No issue, rotates all the way around several times. Ran it with A-720 as well. Did the air machining of the cam program and same as before, the 4th axis pausing when the DRO screen is showing it isn't. It pauses in several areas (at different rotation points, so no consistency in the A-axis stopping at the same spot). At the start of that program it does go all the way around without issue. It is something just before the 2 minute mark that is giving it trouble. And while it is rotating at any speed I can't slow it down by hand, it has a lot of torque.

I tried a bunch of different settings in mach3 that I read about that could cause issues and none of them helped; Enhanced Pulsing (is on), tried Sherline 1/2 pulse thing (made it worse). One strange thing is that I can't get at the motor tuning screen now. When I click motor tuning in the mach3 drop down it doesn't do anything.

So, stumped for now but I do appreciate all the suggestions.


Screen Shot 2022-02-08 at 2.24.21 PM.png

Screen Shot 2022-02-08 at 2.24.57 PM.png
...its possible if you used a small as diameter cutter as possible you would improve the odds since the geometry of the bit and cam line could match better. Its just a thought.

That is a good suggestion since one run I did with a larger cutter (3/16" instead of 1/8") came out worse. But the issue of the rotary axis stopping is certainly causing an issue now that I have to eliminate first.
Can you see the end of the shaft on the back of your stepper motor? If so, put a mark on it and see if the stepper is or is not moving when the work stops moving.
Does it make noise when it is not moving?
Does it return to the commanded position after the program has finished? I do not see an arrow or degree marking on your table. A simple sharpie mark across the table to the casting will give you a good A0 before you run the program.

It is good that you checked inside :) glad it was clean and free.
If you can't stall it by hand, I can't understand what would make it stall cutting air?
No scale in your photos, what size is the stepper nema23?
I can't help much with Mach, it has been many years since I used it.

I took the cover off the motor and made a mark on the shaft:

Screen Shot 2022-02-08 at 4.42.51 PM.png

When the work stops moving, the stepper is stopped as well. Not sure about it returning to the correct start position since I've been stopping it as soon as I see the issue. As I mentioned, it starts stalling very consistently at just before 2:00 into the program.

It must be something in the electronics or the settings that is causing this. Otherwise, the machine and even the 4th axis works well. Other parts I've made on it turned out OK with no issue.

It seems that anyone trying to help does not use Mach3. I suppose me switching over to LinuxCNC is a huge deal? I know nothing about it other than it seems to be popular.
Switching to Linux is either a big deal ( if you know what you are doing ) Or a HUGE deal if you don't. Already being proficient with linux would be a big help. but if you have to learn a new operating system and a new CNC controller it gets tough.
But, It really is that much better and worth the trouble.

After all of that, I don't think it has anything to do with Mach or the code or Windows. It seems to be intermittent and more dependent on time. Have you run other continuous programs that go 2 min. without issue.
It could be heating up or you may have a loose wire.
Get a little fan and let it blow on the 4th axis driver while the program is running.
If it has little dip switches on it make sure they are set for the correct amperage 3Amp I'd guess from your part number
Higher is not better here, it needs to be current limited to 3A. 2.5 would be better than 3.5 ( for getting hot ).

More things to check and consider

Best of luck and keep us posted

That's one small step for a man, one giant leap!

I present you with a machined cam lobe. May not seem like a big deal but it has taken me 2 weeks and a dozen test pieces to get here.

Screen Shot 2022-02-08 at 7.57.05 PM.jpg

I appreciate all the help and suggestions. None of them really helped, but it kept me looking. Scott, switching to Linux is not something I really wanted to do and as you said, I expected it would not be easy. And I have run other programs of over an hour on the CNC (without the 4th axis) and certainly several minutes with that axis. I suspected lately that it has to be a setting in Mach3. The problem is that the person that wrote DeskProto, as well as most people trying to help, don't use it so couldn't offer suggestions related to that. I searched a lot for possible issues and most things I found on the various setting I already had correct. So, what was it you ask?...

I couldn't help but notice that your "Radius Correct" light is not lit.
In your case it may not have to be lit but I always set that for any rotary projects.


Funny you should say that. Before I read your message I was playing around with the various settings in Mach3. Most of which I don't understand but follow what other people have done. I'm pretty sure I tried the radius correct thing yesterday and it didn't help; but I'm not 100% sure. I had trouble getting the Motor Tuning screen to show up and when I finally sorted that out, I checked the settings. This is what I had:

Screen Shot 2022-02-09 at 9.31.34 AM.png

Now for those that use Mach3 but not the 4th axis, the velocity and acceleration probably look crazy fast. But for the 4th axis it is actually degrees per minute (I think...or something similar). I found a reference on-line to someone setting up their machine and they used 485 for acceleration and 2500 for velocity. So I changed to his settings (not sure why it is 2500.2). I also changed the Step Pulse from 1 (I think it was) to 10. I read that even though it says 1-5, you can go up to 15. Not really understanding all of this, I made the changes. I think these setting are only for rapids. And of course I did what you should never do when hunting down a problem, I activated the Radius Correct at the same time, so as to change many things at the same time.

I ran the program, just air machining and didn't get any pauses; be still my heart! I clamped the 4th axis back down and ran the program with a piece of aluminum....and got a proper cam lobe! Cue the hallelujah music!

So what was the issue? I think it was the acceleration, but since I changed a few things I'm not sure. And as long as it keeps working, I'm not keen on changing things just to find out. I don't understand what the radius thing does. Does the program not tell it what speed to run? So why is a material radius input required? And why does it generally still work if you don't use that? I admit I don't understand most of the settings.

Why did this issue come up now and never before with using the 4th axis? I never tried doing "around A-axis" machining before and something in that must have conflicted with my settings. So for anyone that does use Mach3 with a 4th axis, what are your settings for the motor tuning?

Thank you again for all the suggestions. Maybe I'll finally get that camshaft made in only 5x longer that it would have taken me without the CNC.

Last edited:
Thats great ! 👍
And now that I see those screen shots, it's all coming back.
The radius correct thing is for "wrapping" text on a cylinder so it can correct the length of 1 axis for that dia./circ.
I'm thinking now it was your motor tuning.

Let us know if anything funky shows up


I have used my 4th axis with Mach 3 (ESS and G540) on a number of projects. My current settings are attached. I tend to be conservative in my motor tuning.




I have used my 4th axis with Mach 3 (ESS and G540) on a number of projects. My current settings are attached. I tend to be conservative in my motor tuning.

Thank you fellow Canuck!

I generally tend to be conservative in my settings for machining; rather take a bit longer and not chance breaking a cutter. But I seem to have been way out on some of those settings. Not sure where I got the initial ones from. From info on the net on what settings to use for velocity and acceleration, most people say to keep increasing them until the motor can't keep up, then back off a bit. I seem to have started from too high!

And thank you for the picture of your 4th axis. That reminded me that I have a small chuck like that that I should be using on the 4th axis. I'm using an ER collet right now which works fine, but it is also the one I'd like to use to hold the cutter. So if I put the chuck on the 4th axis I can put the ER collet holder back in the spindle.


Latest posts